of scripts & templates that are focused on Wireless Registration Tables
This Version of script, is only for interfaces that are in
1) Access Point Mode, with one connected mac (P2P Links)
2) Client Mode
The main script uses, awk and grep utilities, so they must be installed
on your system
===============================================
Instalation HowTo...
1. Commanding...
The installation is a bit tricky... that's because of ssh usage to retrieve data.
Login at your Routers Winbox/Console
Enable Ssh Service
Code: Select all
/ip service set ssh disabled=no
Code: Select all
/user group add name="cacti" policy=ssh,read,!telnet,!local,!ftp,!reboot,!write,!policy,!test,!winbox,!password,!web
Code: Select all
/user add name="<username>" group=cacti address=<Server IP>/32 comment="" disabled=no
Login to your Linux System as the "web server" user, usually, apache or quest.
Code: Select all
~# login <username>
Password: <password>
Code: Select all
~# mkdir /home/<username>
Code: Select all
~# ssh <Router IP>
The authenticity of host '<Router IP> (<Router IP>)' can't be established.
DSA key fingerprint is 00:00:00:00:00:00:00:00:00:00:00:00:00:00:00:00.
Are you sure you want to continue connecting (yes/no)? yes
Warning: Permanently added 'mtik.kapa.awmn' (DSA) to the list of known hosts.
Code: Select all
/quit
Code: Select all
~# logout
just to install Cacti Scripts at Cacti Dirs .
2. Copying...
Attachment mikrotik_wireless_interfaces.php.txt
as mikrotik_wireless_interfaces.php
at <cactidir>/scripts/
3. Templating...Attachment mikrotik_wirelless_interfaces.xml
as mikrotik_wirelless_interfaces.xml
at <cactidir>/resource/script_server/
Login at your Cacti Interface and import the Templates
4. Cacting...cacti_data_query_mikrotik_get_wireless_interfaces.xml
cacti_data_template_mikrotik_wireless_signal_strength_nic_based.xml
cacti_graph_template_mikrotik_signal_strength_nic_based.xml
Finally go at your precious Device and a Add Data Query named
Mikrotik - Get Wireless Interfaces
Create graphs ... and let it graph